Page 1 of 1

4DO Crash on Launch

Posted: Wed Apr 08, 2015 9:36 am
by ewhac
So, I just built a new machine for myself, and thought to myself, "Self, I'll bet this new rig can finally run a 3DO emulator prroperly." So I downloaded the 4DO installer package, installed it, and it crashed immediately upon launch.

After doing some rudimentary Googling, I discovered that I could get it to launch by running it as an Administrator, but I'd prefer to not have to do that for fairly obvious reasons.

This system is running a very fresh install of Win7 SP1 x64. The crash info in the "problem details" pane is as follows:

Code: Select all

  Problem Event Name:	CLR20r3
  Problem Signature 01:	4DO.exe
  Problem Signature 02:
  Problem Signature 03:	5247c46e
  Problem Signature 04:	mscorlib
  Problem Signature 05:	4.0.30319.34209
  Problem Signature 06:	534894cc
  Problem Signature 07:	4527
  Problem Signature 08:	13c
  Problem Signature 09:	System.UnauthorizedAccess
  OS Version:	6.1.7601.
  Locale ID:	1033
Has this issue ever been solved, or will I need to always run this as an admin?

Re: 4DO Crash on Launch

Posted: Sun Apr 12, 2015 7:07 am
by goldenband
I wish I could help with your problem, but I do want to say that your Kliban reference made me grin. "Evil black spaghetti", "razor-sharp peach slices", "50ccs of BBs and a chicken that can dress itself"...great stuff.

Re: 4DO Crash on Launch

Posted: Mon Apr 13, 2015 8:38 pm
by BryWI
It shouldn't need Administrator access at all. Did you by any chance install it into a folder that the OS would be restrictive about giving permissions for? I don't recall seeing this error yet truthfully.

Re: 4DO Crash on Launch

Posted: Mon Nov 30, 2015 3:55 pm
by MathUser
I ran into this problem with Windows 10. Basically you should download the full version to install all the stuff you need to run the emulator, then after that download the standalone version and that will boot. I don't know why the full version won't boot but I got 4DO working on my computer that way.