Page 1 of 1

Strahl problems on 4DO

Posted: Fri Sep 14, 2012 3:35 pm
by Martin III
Well, I finally got around to downloading 4DO. I'm very impressed with the format and user interface, and I gotta say, I really love the controller config. With most emulators I have to redo the configuration every time because I can't remember what I had previously set the buttons to.


The first game I tried running was the USA version of Strahl. This is straight from the game disc, so no possibility of a bad Rom. Though 4DO's compatibility list marks Strahl as 100% compatible, there are at least two major problems with it. During the introductory cutscene, immediately following the words "Dare ye", the emulator suddenly struggles and then skips over the rest of the scene, jumping immediately to the stage select intro. Then, at the words "is sealed the origin", the same thing happens, and the rest of the intro is skipped.

I tried fooling around a bit - just resets and save states - but I couldn't get the emulator to play the rest of those scenes. I've seen the exact same thing on a YouTube playthrough of the game, too, so apparently it's a common problem.

Posted: Fri Sep 14, 2012 7:42 pm
by BryWI
try beta revision 6...

It will say 4.1 when you unzip it, but it is revision 6. See if that fixes it.

Re: Strahl problems on 4DO

Posted: Thu Sep 25, 2014 5:38 am
by Martin III
Two years later...

I never did get around to trying version, but I just tried Strahl on version and it still has the same problems with the intro scenes. The skips even occur at the exact same points. Also, I guess I didn't mention it in this thread before, but in both versions of 4DO the button prompts in Strahl, and the corresponding die-or-continue triggers, lag behind the FMV.